php 5.6版本,提示我mysql extension快要被弃用 PHP MySQL

最爱鱿鱼丝 9月前 385

我在debug==2(插件开发模式)的情况下发现这个错误,请问应该如何解决呢

最后于 9月前 被最爱鱿鱼丝编辑 ,原因:
最新回复 (8)
  • axiuno 9月前
    引用 2
    修改  conf/conf.php  db  type  =>  pdo_mysql
  • 最爱鱿鱼丝 9月前
    引用 3
    axiuno 修改 conf/conf.php db type => pdo_mysql
    好的,感谢,我改了其中一个default.conf的文件,以为是那里的配置出现问题了
  • 最爱鱿鱼丝 9月前
    引用 4
    axiuno 修改 conf/conf.php db type => pdo_mysql
    另外我发现我开发插件的时候,返回json总是报错
    Deprecated:  Automatically  populating  $HTTP_RAW_POST_DATA  is  deprecated  and  will  be  removed  in  a  future  version. 
    这个应该去哪儿修改呢
  • skiy 9月前
    引用 5
    最爱鱿鱼丝 另外我发现我开发插件的时候,返回json总是报错 Deprecated: Automatically populating $HTTP_RAW_POST_DATA is deprecated and ...
    截图。看具体错误行数及错误的文件。另外不要用它说的那个函数了。要用  file_get_contents("php://input")
  • 最爱鱿鱼丝 9月前
    引用 6


    是类似这一种,不过我搜索过源码并没有发现上面的关键字

  • 最爱鱿鱼丝 9月前
    引用 7
    那个图在楼上,用高级回复好像指引不回你的楼层
  • skiy 9月前
    引用 8
    最爱鱿鱼丝 那个图在楼上,用高级回复好像指引不回你的楼层
    你看看请求了哪个网页,再查看对应的页面。里面是什么代码,再找找看
  • 最爱鱿鱼丝 9月前
    引用 9
    skiy 你看看请求了哪个网页,再查看对应的页面。里面是什么代码,再找找看
    不怎么好定位,我今天再看看这个错误是啥回事
返回
发新帖